Jump to content

Servo buzz and high current draw


GeoffN

Recommended Posts

Hi, 
This is a warning and a cry for help.
I recently had a major crash with my Willow 1 due to a low battery. 
On. the second or third flight of the day I had a low receiver battery warning. I immediately gently nursed the Willow around into a landing circuit nicely  positioned it and then I  stupidly deployed the flaps , that sucked the  last of the power out of the battery  and it went in nose first. Checked the battery and it was indeed flat but cycled okay. I put it down to me not checking the charging properly.  Yes I know I should have checked the charge before each flight.
However after rebuilding both wing boxes I was resetting flap servos this afternoon when I noticed the v-tail servos were buzzing not the normal digital servo whine .The arms were not visibly moving and the linkages were not tight. While investigating I noticed that the buzzing varied with the position of the 2.4 antenna. 
Out of curiosity I checked the current draw of the model and was amazed to find that it was 600 to 800 Ma ! That explains the low battery.
Further investigation showed:-
Model only turned on 150ma
Model and transmitter on, anywhere between 300 and 800 ma depending on the  exact  position of the antenna . The closer the antenna to the servos the higher the current draw. But there are not many options in a F3F fuz to reposition the antenna.
 If I shield the antenna with my hand current draw drops to 250ma and buzzing stops.
Rebinding in non telemetry mode stops the problem. But I got this system for the telemetry! 
The transmitter is a Frsky  X9E and the receiver a X8R bound in D16 mode.Servos jr DS3201 .Battery 1600 2/3 AA. nimh
So any ideas  to stop the interference?  shield the servos , ferrite  cores or what servos can I buy that do not interact?

Link to post
Share on other sites

Change the servos I'm afraid. That servo can't handle proximity to some two way 2.4ghz aerials. As you say you can't remove the aerial far from the rx.

Don't worry your not alone. I experienced this problem with a few servos and it limits your choice. I changed the mks 6125e servos in my stinger for that very reason.

I used to have a jr ds3401 mini servo on the tail of my tragi and that had to go.

Ferrite rings reduced the issue a little on my stinger but it didn't alleviate it. The battery consumption went down a lot.

Second try to use a better battery. 1600 2/3a nimh are usually a lot less than 1600 mah and the voltage curve means the useable capacity is actually less than an equivalent lithium battery. The capacity of batteries is only determined to a nominal point it is considered discharged. With nimhs you can't drain them right down and keep using it.

If you do slow discharge on it you'll see that a lot of the capacity is below 1.2v per cell. If you do a hard discharge the capacity Your charger shows will be way less. Which is essentially the secondary cause of your crash. I.e the flaps put a hard drain on the battery and the voltage dropped too low.

Lithium show less capacity with hard discharge as well, but to a lesser degree. The capacity rating of an 18650 cell is given at a 1amp discharge ( and they keep going right to the end). To get the capacity on the sticker with a nimh you need to discharge at 1/10c or less. 

So you're starting with a 1400mah battery, in reality, from which you can't give current near the end of its capacity.

LifePo4 has a particularly flat discharge curve.

Going back to servos and 2.4ghz there is a thread on here in started ages back about this very subject.

The only answer is change servo or turn telemetry off.

Link to post
Share on other sites

Same problem here with X4R and servos supplied with both Alula and Ahi. Solved by swapping X4R for MPX RX-5 light + MPX rf module. Didn't think of binding  in non telemetry mode but if it completely cures the issue then this is the method I'd go for assuming you're confident with range (it's amazing how quickly one can adapt to the 'old' ways - for my Needle I don't rely on voltage telemetry for the LiFe cells, instead I use a simple timer...).

Link to post
Share on other sites

There are some posts on other forums that suggest that a capacitor between signal and ground or wrapping the receiver in foil and connecting the foil to ground works.Tried them and ferrits cores but no effect.

Last idea to try is to use a long antenna and put it as far down the fuz as posible ,only one seems to transmit telemetry.

Going to move to life batterys and use a couple of diods to drop the voltage.

Geoff

Link to post
Share on other sites

If you plug a sensor in you will find it's worse as memory serves. E.g the vario.

I would change the servos  as well as the battery. The little blue bird hv105 / 106 / 107 are good value. 

Putting the servos in a lead box would probably work!

Link to post
Share on other sites

Hi I think I might have solved the problem or at least got a work around.

I've fitted extension antenna one 60cm one 20 cm no buzzing.The 20cm one is right up in the nose. The 60 cm one will be threaded down the fuz towards the tail . I'm not sure if there is any carbon down there ( anybody know?) if there is I'll pop the antenna up through a hole in the fuz about 7 cm behind the wings, this works a treat on the all carbon fuz of my Opus. I did originally put it out of the nose but it was bashed about a bit landing in bracken and heather.

Now the readings get are: -

with extension ant  tx off 140ma 
with ext antenna tx on 170ma 
with tx on openxsensor altimeter 190ma
with tx on openxsensor gps only 230 ma

I was suprised at how much current was drawn by a normaly buzzing servo upto 150ma per servo.

Next project openXsensor current sensor. I'm getting paranoid now.

Now all I have to do is get the antenna past the wing joiner and the balast tube.

  • Like 1
Link to post
Share on other sites

Correction!  The antenna mod I did in my previous post only works 50% of the time. It would appear that the X6r picks a random antenna on power up to transmit the telemetry.  So if it picks the long antenna no buzzing, if it picks the short antena the buzzing is back. I'm begining to long for the simple days of 35meg.

  • Like 1
Link to post
Share on other sites

I use telemetry a lot with my MPX stuff and haven't seen this, but then again I haven't used any of these servos, is this a generic 2.4 issue with certain servos or just with specific radios?

Link to post
Share on other sites
  • Committee Member
PeteMitchell
1 hour ago, satinet said:

Very much certain servos.

Thankfully never encountered this problem, and I use telemetry on all my gliders, every flight.

Be helpful to know what servos  are suspect?

Link to post
Share on other sites

Mks 6125 all including the one that's a vtail servo (6125e). Mks 6100 seems ok.

Jr mini all I've tested. Some jr wing servos.

Sanwa sdx762/airtronics 761

All futaba servos I've tested are fine. Blue bird also ok. Although blue birds can turn off mag switches! 

 

 

Link to post
Share on other sites
  • Committee Member
PeteMitchell

Thanks Tom.

Never used the 6125e but many 6100  in both fuselage and wing, also 6125 mini in the wings.

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Who's Online   2 Members, 0 Anonymous, 19 Guests (See full list)

    • Feefo
    • Dave1968
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.